Deepstack and BI on separate machines... Need help

I have BI on one machine and deepstack on a separate machine (all windows machines).

I launch deepstack through powershell with the command
deepstack --VISION-DETECTION True --PORT 83

It starts, Blue Iris machine can see the welcome screen, blue iris is set to use that machine for deepstack.

Here is my issues:

BI gets a detection, Log file created says this:
0 11/17/2021 10:40:32.597 AM Cam1 DeepStack: Alert cancelled [DeepStack: -1] 38ms

I have BI set to process 5 images, analyze one each: 1 sec

Watching the powershell window on the other machine, I see (ip hidden):
[GIN] 2021/11/17 - 10:40:33 |←[90;43m 403 ←[0m| 8.3081ms | 192.168.x.x |←[97;46m POST ←[0m “/v1/vision/detection”

So, It appears they are talking to each other but deepstack doesn’t appear to be processing anything that I can see. Every alert gets cancelled. I just had a delivery driver show up In a car even and stood in front of that camera for a couple minutes, all alerts cancelled.

Any ideas why this isn’t working?

I also can’t seem to get deepstack reports in blue iris status reports,even though I have it checked in the camera settings. The report just stays blank. I don’t know if this is because deepstack is on different computer so that function doesn’t work or what.

403 error would be a permission thing, no? pc receives request, but purposely doesn’t allow/respond. not sure how to correct, but maybe that helps as a starting point? (I assume both pcs are on the same subnet IP due to the request showing up, but if not, check that)

Following. Very similar issue.

Seperate machines.
Linux GPU deepstack
Windows Blueiris.

Looks like they are being processed by deepstack but Blue Iris says it’s not responding but provides ms 9f time taken to process.

Never mind, we are having different issues. My processes were taking micro seconds. So there’s a good chance deep stack isn’t working as I’m pretty sure that is way too quick.

Edit…

Here is my information from Deepstack

[GIN] 2021/11/20 - 22:09:11 | 403 | 67.823µs | 192.168.0.204 | POST “/v1/vision/detection”
[GIN] 2021/11/20 - 22:09:11 | 403 | 71.091µs | 192.168.0.204 | POST “/v1/vision/detection”
[GIN] 2021/11/20 - 22:09:29 | 403 | 229.232µs | 192.168.0.204 | POST “/v1/vision/detection”
[GIN] 2021/11/20 - 22:09:29 | 403 | 144.442µs | 192.168.0.204 | POST “/v1/vision/detection”
[GIN] 2021/11/20 - 22:10:23 | 403 | 209.882µs | 192.168.0.204 | POST “/v1/vision/detection”

On Bueiris . The log says "DeepStack: Alert cancelled [DeepStack: not responding] 216ms … ect ect

Not sure if you have “-e VISION-DETECTION=True” in your parameters when start deepstack.

Not to be confused with “-e VISION-SCENE=True”

Adding that top line fixed my 403 error. But now i have more issues then that.

My startup looks like this:
sudo docker run --gpus all -e VISION-SCENE=True -e VISION-DETECTION=True -v localstorage:/datastore
-p 80:5000 deepquestai/deepstack:gpu-2021.09.1

The windows version doesn’t allow the -e command. I tried several variations. It does not like it. It doesn’t like -e -v -p. Its like trying to find a needle in a haystack but you don’t know your actually hunting for a needle because nothing is explained to you.
What is 403, who is giving the 403 error. Is it deepstack not liking something in its configuration or is it not liking something blue iris is sending over? Incredibly frustrating experience.

This is what tipped me off. There was a couple people referencing the Vision Detection endpoint in it. Although like you said, this may not be whats happening to you.

Have you tried:
deepstack --VISION-SCENE=True --VISION-DETECTION=True --PORT 80

Just throwing random things out there. As I just beat the problem to death until something finally stuck on my end.

Yes That’s how I initially did it cause that’s what shows in the windows section of installation instructions.

In fact you will notice the example says deepstack --VISION-DETECTION True --PORT 80
Notice the missing = for true. It works both ways but either was still gives the 403 in the response.
I uninstalled, reinstalled, no change. I ran it from powershell window and powershell admin window, same response.

So I can’t tell if this is a blue iris issue or a deepstack issue. To me it almost feels like BI isn’t sending over the jpg’s
I can hit trigger on a camera and its milliseconds that I see the 403 screen on the deepstack machine.