Deepstack Error 500 on Jetson Nano 4GB with yolov5 Models

Hi,
so since 2 Days I’m now trying to get one of the Yolov5 Models to work with Deepstack on the Jetson Nano.
The Implementation of the Model itself work’s flawlessly, but uppon excecution of a Scan, Deepstack times out:

DeepStack: Version 2022.01.1
---------------------------------------
v1/vision/custom/yolov5n
/v1/vision/detection
---------------------------------------
---------------------------------------
v1/backup
---------------------------------------
v1/restore
[GIN] 2022/05/13 - 21:42:09 | 500 | 1m0s | 192.168.10.200 | POST /v1/vision/custom/yolov5n

In the Logfile /app/logs/stderr.txt the following Messages appear:

File “/app/intelligencelayer/shared/detection.py”, line 68, in
** detector = YOLODetector(model_path, reso, cuda=CUDA_MODE)**
** File “/app/intelligencelayer/shared/./process.py”, line 31, in init**
** self.model = attempt_load(model_path, map_location=self.device)**
** File “/app/intelligencelayer/shared/./models/experimental.py”, line 158, in attempt_load**
** torch.load(w, map_location=map_location)[“model”].float().fuse().eval()**
** File “/usr/local/lib/python3.6/dist-packages/torch/serialization.py”, line 584, in load**
** return _load(opened_zipfile, map_location, pickle_module, pickle_load_args)
** File “/usr/local/lib/python3.6/dist-packages/torch/serialization.py”, line 842, in _load**
** result = unpickler.load()**
AttributeError: Can’t get attribute ‘SiLU’ on <module ‘torch.nn.modules.activation’ from '/usr/local/lib/python3.6/dist-packages/torch/nn/modules/activation.py

I’ve tried several Versions of JetPack an Deepstack. Every single combination with the same Results.
So am I missing something? Does someone know a solution for this ?
At this Point I’m pretty tired and close to giving up…

Maybe check here:

Could be a torch version mismatch.

Hi, thanks fo the reply. I already tried that. Updating torch removes the original Error which is then replaced by another. I think it’s a librarie that can’t be found. So I think the Image in general is a little bit outdated.

Runnning:
$ git clone GitHub - ultralytics/yolov5: YOLOv5 🚀 in PyTorch > ONNX > CoreML > TFLite
$ cd yolov5
$ pip install -r requirements.txt

doesn’t work neither.
So to be clear: All thinks need to be changed inside the Dockercontainer and not on the Nano itself, right ?

@Idefix Thanks for posting on this issue. At the moment, DeepStack only supports YOLOv5x, YOLOv5l, YOLOv5m and YOLOv5s and the model must be trained using the deepstack-trainer documented here