Deepstack on Raspberry install is not working

I’m trying to install deepstack on raspberry pi with movidius stick (https://python.deepstack.cc/raspberry-pi). Tried both with python 3.5 and 3.7 (3.7.2) but I always get error building wheel for scipy.

If scipy fails on install (wheel for scipy) is possible to install that package via apt (python3-scipy) and comment out the scipy part in the install-deepsatck.sh.
On headless pi some packages are missing, in my environment i had to install (via apt) libopenjp2-7 libgtk-3-0 libgtk-3-dev libtiff5

With NCS2 the provided setupvars.sh seems not working. I had to use the openvino official.
modify /usr/bin/deepstack according to:
source /opt/intel/openvino/bin/setupvars.sh instead of the deepstack one. (openvino guide at https://docs.openvinotoolkit.org/latest/_docs_install_guides_installing_openvino_raspbian.html )

Now the setup is working on Pi3 with Raspbian Stretch and NCS2, average prediction in 1 - 2 seconds