DeepStack Windows Version - Beta Update

Hello everyone, thanks for the incredible feedback on the windows version.
To address some of the issues raised, we are excited to share the second beta for both the CPU and GPU Versions.
Major Fixes here include.

  • MODE is now supported
  • 500 internal server error after running for some hours due to windows clearing temp dir has been fixed.

Download and Install the Latest Version here
Release DeepStack Windows Beta 2 · johnolafenwa/DeepStack (github.com)

1 Like

Thanks for this release.
First feedback with GPU version and 720p image

1 - First iteration is still very high
2 - Performance is 4x slowest than first release (+200ms versus 50 ms)
3 - Mode = High is 6x more slowest than first release (+400ms versus 50 ms)

for information Rpi4 + NCS is 277ms

1 Like

I get the around the same performance decrease on my P2000 on 1920x1080 images as @vlitkowski reports.
Beta 1: average at 80-90ms
Beta 2 no MODE set: average at 320ms
Beta 2 with MODE = high: average at 730ms
Beta 2 MODE = Low: average 230ms

1 Like

Hello @vlitkowski and @MissMusic, thank you for reporting this performance issue. This must be a bug, as the performance isn’t supposed to be changed in this update. Will investigate and release a fix shortly.

2 Likes

GPU version does not seem to be using the GPU.

2 Likes

Yea something is off, it’s not using as much CPU as the old windows release (before GPU support existed) but clearly a lot more than GPU beta 1.
I rolled back to 2020.12 release as for now. My system were unable, even on low settings, to process images fast enough on beta 2021.01.

Hello @Tinbum @MissMusic @vlitkowski, this has been fixed.
See the latest release here

2 Likes

Running 2021.01.1 now and it seems good performance-wise. It performs like the 2020.12 release on default settings, and on --MODE High i get about a 50% increase in processing time (~90ms compared to previous ~60ms).

Thanks, I’ll run this for a while and see how it behaves.

2 Likes

Thanks for the feedback. The High mode should behave similarly to the docker High mode

I have not had the chance to run the docker versions before. Initial testing seem good for High mode, i have removed some masks on areas that gave false positives before and have no such hits so far.

Thanks a lot for this awesome tool.

1 Like

so i have a curious things going on LOL. This works great on windows 10 with a GTX1080. If i run it on my server 2019 machine with a tesla k40m. it runs for a second. If i watch process hacker. I see it come up and start, then after 1 second Python goes red and then closes leaving just deepstack and redis running.

What could be the reason that since I’m using the new windows version, including this update, I’m getting a lot of Task Canceled Exceptions?

It occurs everytime I try to register a new face but also in about 1/100 images that I analyze.
The log of my program gets this:
System.Threading.Tasks.TaskCanceledException | A task was canceled. (code: -2146233029 )

Running 2021.01.1 fixed…
It runs better, thanks for the quick fix
30% performance decreased compared to 2020.12 but … same performance with mode=high !
70ms now versus 50ms
I’m running a GTX 1060 with i7 7700k

1 Like

I have same issue on one computer but other runs fine.

Both running windows 10 the one that’s ok has a GTX 1050 Ti the other is a GTX750 Ti

error ‘Key already registered with the same priority: GroupSpatialSoftmax’

Edit- now doing it on the other computer after a reboot.

Hi @john.

Just tried this update, but still getting the hanging scene detection. Looking at the logs its the same Cannot load onnxruntime.capi. Error

Was this release intended to fix this? Is there anything I can do locally to try workaround the issue? I do have VS2017/2019 installed as I do other development.

Hello @fogkeebler , thanks for sharing this. Please run this and share logs from AppData/local/DeepStack/logs/stderr.txt
This will help us fix this issue.

Hello @Tinbum, please share logs from running this so we can fix it.

Hello @mrpie, this error is coming from AI tool i believe, share the logs from AppData/local/DeepStack/logs/stderr.txt

Unfortunately i gave up on this working and cleared the system to use it for something else. But I am not opposed to recreating it. I have looked in that log file before and there was nothing in it. so how do i run it?

Thanks for your help.
It’s having this strange behavior that sometimes I’m able to register or detect a new face, but most of the times I get this error.
Also I tried to recognize a face using Postman and it doesn’t work, it gets stuck loading, so the Task Canceled Exception that I’m seeing is because a HttpClient.Timeout .
Hopefully you may have an idea of what the problem is.

The stderr.txt has:

Process Process-2:
Traceback (most recent call last):
File “C:\DeepStack\intelligencelayer\shared\face.py”, line 186, in face
det = detector.predict(img, 0.55)
File “C:\DeepStack\intelligencelayer\shared.\process.py”, line 47, in predict
img0 = Image.open(img_path).convert(“RGB”)
File “C://DeepStack\windows_packages\PIL\Image.py”, line 2891, in open
fp = builtins.open(filename, “rb”)
FileNotFoundError: [Errno 2] No such file or directory: ‘C:\Users\angel\AppData\Local\Temp\DeepStack\f3364380-2866-4fc9-9ee9-baeb357360eb’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “D:\obj\windows-release\37amd64_Release\msi_python\zip_amd64\process.py”, line 297, in _bootstrap
File “D:\obj\windows-release\37amd64_Release\msi_python\zip_amd64\process.py”, line 99, in run
File “C:\DeepStack\intelligencelayer\shared\face.py”, line 253, in face
except UnidentifiedImageError:
NameError: name ‘UnidentifiedImageError’ is not defined

Postman screenshot: