Error: nvidia-container-cli: requirement error: unsatisfied condition: cuda>=11.3

Is it just that my card isn’t supported? The full error is below.
My card is a GeForce GTX 750 Ti.
nvidia-detect says to use nvidia-legacy-390xx-driver

docker run --gpus all -e VISION-DETECTION=True -e MODE=Low -p 5323:5000 deepquestai/deepstack:gpu

docker: Error response from daemon: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: Running hook #0:: error running hook: exit status 1, stdout: , stderr: nvidia-container-cli: requirement error: unsatisfied condition: cuda>=11.3, please update your driver to a newer version, or use an earlier cuda container: unknown. ERRO[0000] error waiting for container: context canceled