Error when using gpu docker

Hi,

I’m getting this error message when trying to use the GPU docker

2021-03-04T19:03:42+01:00 [Trigger Car detector] Error: Failed to call DeepStack at http://10.7.1.2:5000/: {"success":false,"error":"Detection endpoint not activated","duration":0}

This is running on this pc:

vendor_id       : GenuineIntel
    cpu family      : 6
    model           : 60
    model name      : Intel(R) Xeon(R) CPU E3-1231 v3 @ 3.40GHz
    stepping        : 3
    microcode       : 0x28
    cpu MHz         : 3592.607
    cache size      : 8192 KB
    physical id     : 0
    siblings        : 8
    core id         : 3
    cpu cores       : 4
    apicid          : 7
    initial apicid  : 7
    fpu             : yes
    fpu_exception   : yes
    cpuid level     : 13
    wp              : yes
    flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm cpuid_fault epb invpcid_single pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida arat pln pts md_clear flush_l1d
    vmx flags       : vnmi preemption_timer invvpid ept_x_only ept_ad ept_1gb flexpriority tsc_offset vtpr mtf vapic ept vpid unrestricted_guest ple shadow_vmcs
    bugs            : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit srbds
    bogomips        : 6784.98
    clflush size    : 64
    cache_alignment : 64
    address sizes   : 39 bits physical, 48 bits virtual
    power management:

GPU:

mist@durian:~/docker/deepstack$ sudo docker exec -it compassionate_banach nvidia-smi
Thu Mar 4 18:09:28 2021
±----------------------------------------------------------------------------+
| NVIDIA-SMI 450.102.04 Driver Version: 450.102.04 CUDA Version: 11.0 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 GeForce GTX 106… Off | 00000000:02:00.0 On | N/A |
| 0% 21C P8 4W / 120W | 1038MiB / 6076MiB | 0% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
+-----------------------------------------------------------------------------+

Not sure how to proceed. Any help is appreciated

@mist0706 Did you add -e VISION-DETECTION=True to your command for starting DeepStack?

Follow the link below for the full commands for running DeepStack with object detection.

https://docs.deepstack.cc/object-detection/index.html#starting-deepstack