Face endpoints not activated


#1

I have run:

sudo docker run -e MODE=High -e VISION-FACE=True -v localstorage:/datastore \ -p 80:5000 deepquestai/deepstack

Yet I get the error ‘Face endpoints not activated’ - should this not return detected faces regardless of whether I have registered them or not?
Thanks


#2

Hi @robmarkcole , thanks for calling our notice to this. We have been trying to reproduce this error without success. In the mean time, you might try restarting the server and see if it persists. Also, what which of the Face API urls was generating the error; /face , /face/register , face/recognize, /face/list , /face/delete or face/match ?


#3

http://localhost:80/v1/vision/face from detection


#4

I am still unable to reproduce this error. Are you running the latest Image?
And have you tried any other endpoint?


#5

HI @john yes the latest image, pulled yesterday. The docs state:
`
For example, to use any face API, you should run deepstack as below

sudo docker run -e VISION-FACE=True -v localstorage:/datastore \ -p 80:5000 deepquestai/deepstack

In this example, you can query all face related APIs, however, you cannot query the object detection API and other endpoints.
`
So face detect should be active?

Object detection is running fine.

UPDATE: I tried face detect again (after object detection) and now it is working correctly…!


#6

Hello @robmarkcole, am happy its working now. The docs has been moved to http://dev.deepstack.cc

The old docs would soon be archived. In few days, we shall be releasing a new update with better performance, less cpu usage and universal support for models trained with any deep learning framework.

Would keep you updated.


#7

Really looking forward to v3 :slight_smile: