Fix Windows Versions?

I have reported the fact that the latest Windows versions (GPU and CPU) are not detecting objects. However, I haven’t received any response to indicate that this report has even been read.

Is this issue being looked into? Has anyone else verified or refuted this?

1 Like

Hi @Ken98045 , to truly understand the cause of the issue you are having, kindly give more details on the following

  1. If you run DeepStack with version number 2021.09.1, does it detect the objects (CPU and GPU)?
  2. For latest version, have you tried other APIs (Face, Scene, Enhance)? Do they respond with results?
  3. If none of the API is giving results for the latest version , provide the following
    • Platform installed ( DeepStack Windows Native, Docker)
    • How you are interacting with DeepStack (DeepStackPython SDK, Python/any other language requests, BlueIris, etc)
    • DeepStack logs in the Terminal is responding
    • A sample of the image fed into DeepStack
    • GPU and/or CPU specs of the host machine

(1) I have tried the latest 2021.09.1 Windows Native versions for both GPU and CPU versions. I have tried with the new thread count option set and not set.
(2) I am using /v1/vision/detection with the default models.
(3) The call to DeepStack return 200/OK, but it does not return a list of objects. The processing time for the call seems appropriate/realistic.
(4) The only thing different between DeepStack that does return objects, and DeepStack that does not is the latest version. The picture is the same. However, I have tried over 100 pictures that return objects with the previous version. No objects are recognized in any picture.
(5) I am interacting with DeepStack from C# using standard HTTP calls.
(6) DeepStack does show the request in the Terminal.
(7) I am using an AMD 5650 processor with 8 core/16 thread. I am using a relatively recent model NVidia card with CUDA (optionally)
(8) Again, both GPU and CPU versions return 0 objects on ALL pictures. There is nothing challenging/unusual about these pictures. The include people/vehicles.
(9) The previous version return objects in all test pictures (as it should).

If I can provide any additional information you can email me at DeepStack@aperson.me if you wish. The forum does not currently send out emails (a problem if you ask me), so I may not see any response by you instantly. However, I will check back periodically.

I have been using DeepStack for over 18++ months, and this is the first version that just doesn’t work. In fact, I have an open source application (On Guard Version 3.0) that is available on GitHub, so I don’t think I’ve made any stupid mistakes. You can try that application if you like as well.

2 Likes

Sorry, the version I tried that is not working is the latest (January 2022) version. The September version does work. Apparently I did a copy/paste of the version from someplace. I can’t seem to edit the original post. Everything else in this post is correct. The latest Windows version just isn’t working for me.

1 Like