GPU 2022.01.1 - no objects detected

I am getting no objects detected for Windows CPU and GPU. I get a 200/OK returned - just nothing detected. Everything identical/same picture with the previous version and objects are detected.

Sorry, I posted this on a couple of other topics with no response. Thought I’d mention that here too.

1 Like

510.54 driver and CUDA 11.6 are available through the graphics-drivers PPA so I updated and… no change, still getting an empty set returned.

@OlafenwaMoses I’m just using one of the stock images from @robmarkcole 's deepstack-ui container: https://github.com/robmarkcole/deepstack-ui/raw/master/app/street.jpg

1 Like

I am also having a similar issue with objects not being detected with the new GPU version. I created a separate thread with all the information I was able to gather - Unable to get GPU version working on docker

any updates here? I just pulled the gpu docker image, and it returns 200, but no objects detected.

I’m running the CPU version side-by-side, and that works just fine with the same source.

For me only this version works with the GPU - gpu-2021.09.1

Hi folks, we have performed a number of testing on the January 2022 release of DeepStack for Windows (CPU & GPU) and Docker (CPU & GPU) and we have not being able to replicate this bug.

We recognize a number of users are experiencing this and we will continue to work on replicating and fixing the issue.

Temporary suggestion: Have you tried testing it on a different machine of on a virtual machine perhaps? Does the problem persists?

2 Likes

My instance is running on a virtual machine. The issue is present even after a fresh reinstall on a new VM.

1 Like

This only appears to be an issue with newer cards. The Jan release works fine with a Quadro k1200/4gb (BlueIris/W10 system) but when swapped for a T600/4gb (Turing based card similar to a GTX1650), it stops detecting objects. Everything is the same (driver, cuda version 11.5 and cudnn 8.3.3). In that case, uninstalling DS and going back to the Sept 2021 release fixes the issue.

4 Likes

I can report something similar as vulture1. Using linux OS with a P400 and it works just fine. When I switch the card to a T600, it stops working. Nothing changes in between.

2 Likes

I have the same problem. I changed my old GTX 650 which didn’t work with Deepstask-GPU to Nvidia T600, it works, but doesn’t return any objects to “Agent DVR”.

Also,

Same problem here… worked fine with CPU version, then installed a Nvidia GFX 1660S and upgraded to the gpu docker image and now it returns 200 but no object detected.

edit-
Downgraded to gpu-2021.09.1 and now it works :slight_smile:
edit-

@hflatoey Thanks for reporting this. We noticed latest DeepStack GPU works on some GPUs and doesn’t on others. We traced this to recent bump in the PyTorch version which caused a number of issues on different CUDA versions… As mentioned in an earlier post in this thread, we are working on multiple DeepStack GPU version releases that will target different CUDA versions, ensuring compatibility with your individual graphics cards.

3 Likes

Hello, do you have a fix for the GPU version to work on Blue Iris? I have a Quadro T400 GPU and in version 2022.01.01 it doesn’t work at all. Only in version 2021.09.01 it works very well.
I would like to use a newer, better-identified version.

Yes, we’ve all been waiting for months. You can see my earlier posts on this. I believe that if you use an older version of CUDA the GPU version may work with the current DeepStack. You can read the DeepStack installation instructions to get that version number. It might or might not be available due to the more recent CUDA releases.

The last I heard the authors were working on a fix for using current/multiple CUDA versions. However, that has been months and my guess (not having looked at the code) that that wouldn’t take all that long.

Thank you for this!! I’ve been banging my head against the wall trying to get this to work for weeks. I finally have deepstack working on my GPU by rolling back to the 2021.09.1 and I finally have deepstack running on my GPU. I see they have a fix coming so I’ll keep an eye out and wait for that.

Good morning, any resolution or version that works on GPU? I’m looking forward to updates.

I am getting no results from GPU Docker on Ubuntu LTS 22.
NVIDIA-SMI 515.65.01 Driver Version: 515.65.01 CUDA Version: 11.7

I see a defunct REDIS server. I get a response 200, but no predictions.

tried deepstack:gpu and :gpu-2022.01.1 no difference.

I’ve given up on this being resolved… replaced my Deepstack container with CodeProject.AI Server, it’s API-compatible so my client apps are none the wiser.

I’m getting <80ms object detection against 4MP camera images with a GTX 1660 Ti.

I tried it with CodeProject and it didn’t work well, it took more than 1000 ms to identify and it used 100% of the memory of my Quadro T400 GPU with 2 GB.
With the deepstack I’m using the 09.2021 version identifies very well with an average response time of 380 ms.
I’ve tried several times to install Deepstack version 2022, but it doesn’t identify.