Issues with June and September version on jetson nano

I’m looking for some assistance getting deepstack running on a jetson nano. I had February release running a few months ago, but i was having issues with my cameras at the time. Now I have the cameras fixed and I am having issues with deepstack.

I’ve tried fresh installs of jetpack 4.5 and 4.6 with the September and June jetpack release. Every detection times out with status code 500 after 1 minute. The output of /app/logs/stderr.log:

Traceback (most recent call last):
File "/app/intelligencelayer/shared/face.py", line 18, in <module>
import torch
File "/usr/local/lib/python3.6/dist-packages/torch/__init__.py", line 188, in <module>
_load_global_deps()
File "/usr/local/lib/python3.6/dist-packages/torch/__init__.py", line 141, in _load_global_deps
ctypes.CDLL(lib_path, mode=ctypes.RTLD_GLOBAL)
File "/usr/lib/python3.6/ctypes/__init__.py", line 348, in __init__
self._handle = _dlopen(self._name, mode)
OSError: libcurand.so.10: cannot open shared object file: No such file or directory

Docker Compose:
volumes:
deepstack:

  deepstack:
    container_name: deepstack
    image: deepquestai/deepstack:jetpack-2021.09.1
    restart: unless-stopped
    ports:
      - 5000:5000
    environment:
      VISION-FACE: 'True'
      MODE: Low  #High
      runtime: nvidia
      api_key: xxxxxx
    volumes:
      - deepstack:/datastore

Sorry, this was an issue with how I installed docker-compose.

Hello… Care to share how you fixed yours? I’ve get to get past this error and not sure where to look next. Identify errors as you had.

Thanks,
M