Latest GPU version error 500 (timeout)

since updating to the latest, I’m getting timeouts

Before:

After:

1 Like

Fixed after upgrading to the latest NVIDIA drivers (510) and CUDA (11.6)

1 Like

@elad.bar Is this the Docker GPU or Windows Native GPU?

Im getting same error. Any advice how to debug this?
Win 10 - new install i=on ESXI with Nvidia vgrid drivers
Installed Cuda 11.6
copied CUDNN 8.3.2.44 folders to CUDA/11.6

added path variable for zlibstat.lib.
Installed Deepstack GPU 2022.01.1 to C:\deepstack
Installed Blue Iris

Blue Iris complains with “could not start, check Path” on C:\deepstack
Fix is to copy deepstack.exe and rename to server.exe

If I start Deepstack from powershell I get: 500 and 200 errors

PS C:\Users\Admin> deepstack --VISION-SCENE=True --VISION-DETECTION=True --PORT 83
DeepStack: Version 2022.01.01
/v1/vision/detection

/v1/vision/scene


v1/backup

v1/restore
[GIN] 2022/01/23 - 12:20:08 |←[97;41m 500 ←[0m| 1m0s | 127.0.0.1 |←[97;46m POST ←[0m “/v1/vision/detection”
[GIN] 2022/01/23 - 12:20:08 |←[97;41m 500 ←[0m| 1m0s | 127.0.0.1 |←[97;46m POST ←[0m “/v1/vision/detection”
[GIN] 2022/01/23 - 12:20:08 |←[97;41m 500 ←[0m| 1m0s | 127.0.0.1 |←[97;46m POST ←[0m “/v1/vision/detection”
[GIN] 2022/01/23 - 12:20:09 |←[97;41m 500 ←[0m| 1m0s | 127.0.0.1 |←[97;46m POST ←[0m “/v1/vision/detection”
[GIN] 2022/01/23 - 12:20:17 |←[97;42m 200 ←[0m| 48.6614873s | 127.0.0.1 |←[97;46m POST ←[0m “/v1/vision/detection”
[GIN] 2022/01/23 - 12:20:17 |←[97;42m 200 ←[0m| 12.0501625s | 127.0.0.1 |←[97;46m POST ←[0m “/v1/vision/detection”
[GIN] 2022/01/23 - 12:20:19 |←[97;42m 200 ←[0m| 1.6117151s | 127.0.0.1 |←[97;46m POST ←[0m “/v1/vision/detection”
[GIN] 2022/01/23 - 12:20:19 |←[97;42m 200 ←[0m| 1.6250753s | 127.0.0.1 |←[97;46m POST ←[0m “/v1/vision/detection”
[GIN] 2022/01/23 - 12:20:49 |←[97;42m 200 ←[0m| 271.5435ms | 127.0.0.1 |←[97;46m POST ←[0m “/v1/vision/detection”
[GIN] 2022/01/23 - 12:20:52 |←[97;42m 200 ←[0m| 272.6991ms | 127.0.0.1 |←[97;46m POST ←[0m “/v1/vision/detection”
[GIN] 2022/01/23 - 12:20:52 |←[97;42m 200 ←[0m| 569.0446ms | 127.0.0.1 |←[97;46m POST ←[0m "/v1/vision/d

Docker GPU

1 Like

I figured out the issue with Blue Iris starting DeepStack version 2022.01.1. The issue was DS version 2021.09.01 had two of the same files just named differently in folder “C:\DeepStack\server” one was named deepstack.exe and the other was named server.exe. Blue Iris is trying to starts up server.exe. DeepStack version 2022.01.1 only has one file in folder “C:\DeepStack\server” named deepstack.exe. The fix was copy deepstack.exe in the same folder with the file name server.exe.

2 Likes