No valid image file found intermittently

Hello. I have installed Deepstack on WSL that runs an Ubuntu image. When I try to process an image by making a request using Postman, I’m getting No valid image file found intermittently where only half of the requests work. In Deepstack logs, the requests that fail have a 400 response. All of these request are the same, I’m just making them in sequence.

[GIN] 2020/12/29 - 15:44:52 | 200 |    466.1831ms |      172.18.0.1 | POST     /v1/vision/face/
[GIN] 2020/12/29 - 15:44:54 | 400 |       9.174ms |      172.18.0.1 | POST     /v1/vision/face/
[GIN] 2020/12/29 - 15:44:56 | 200 |    229.7854ms |      172.18.0.1 | POST     /v1/vision/face/
[GIN] 2020/12/29 - 15:44:58 | 400 |        8.06ms |      172.18.0.1 | POST     /v1/vision/face/
[GIN] 2020/12/29 - 15:45:00 | 200 |    284.9899ms |      172.18.0.1 | POST     /v1/vision/face/
[GIN] 2020/12/29 - 15:45:01 | 400 |      7.1331ms |      172.18.0.1 | POST     /v1/vision/face/

I’m launching Deepstack using docker-compose.

version: '3.3'
services:
   deepstack:
      container_name: deepstack
      restart: always
      ports:
         - '8090:5000'
      volumes:
         - '~/docker/deepstack:/datastore'
      tty: true
      stdin_open: true
      environment:
         - VISION-FACE=True
      image: 'deepquestai/deepstack:latest'

Running WSL 2 in my laptop which has Intel® Core™ i7-8550U with 8GB of memory. Any ideas of why this is happening?

How are you calling Deepstack - with a script?

@robmarkcole No script, I just created the request in postman and I’m manually making the requests in sequence.

@etricky for best performance on Windows operating system, I will advice you install the native windows version. Find details via the link below.

https://docs.deepstack.cc/windows/