Not able to install DeepStack on RPI4

OS: Raspbian Buster / Latest
Environment: RPI4, 2GB
Docker
NCS2 from Intel

How To:

  1. docker pull deepquestai/deepstack
    Download and extract ok
  2. sudo docker run -v localstorage:/datastore -p 5000:5000 deepquestai/deepstack
    return
    standard_init_linux.go:211: exec user process caused "exec format error"

Other methods

  1. Try the method described here
  2. Manually install all the missing libraries // Running on Python 3.7.3
  3. Building wheel for scipy (PEP 517) … takes a lot
  4. Result:
    Building wheels for collected packages: scipy
    Building wheel for scipy (PEP 517) …
    (it stucks on this step)

Also tried

  1. Manually install ```
    sudo pip3 install scipy --extra-index-url https://www.piwheels.org/simple
No change!

Are you trying to install Deepstack on the Pi through Docker or natively? My understanding is that it doesnt work through Docker on a Pi 4 (or at least thats not how I got it working)

Big step for me was to download Buster Desktop edition and run the download script and it worked - more info here: Intel® Movidius™ Neural Compute Stick support?

Hi @Jaysbeekay. I tried both methods. Finally I understood that the Docker image is not suitable for arm processors. So, I tried this https://python.deepstack.cc/raspberry-pi
Building wheels for collected packages: scipy
Building wheel for scipy (PEP 517) …
(it stucks on this step)

wget https://deepquest.sfo2.digitaloceanspaces.com/deepstack/install-deepstack.sh

install-deepstack.sh

simple///

As I mention this method leads to
Building wheels for collected packages: scipy
Building wheel for scipy (PEP 517) …
(it stucks on this step)

Solved! Fresh install on Raspbian Buster Desktop. Takes a some for scipy but installation was successfully.

Closed!

Hi, I have used same method for installation of deepstack on RPI4 (using install-deepstack.sh). It seems to be running fine, but it looks like it requires activation. Have you managed to activate it?
As I understand there is no docker container version available for RPI4, right?

Nope, I didn’t.

I’m expecting guidance from @OlafenwaMoses.

1 Like

@Jaysbeekay @vlitkowski @CarpeDiemRo @cigas4

Hi everyone, we now have a new DeepStack version for Raspberry Pi + other ARM devices and it doesn’t require an activation key!. Check out the post linked below.

1 Like

Hi, great news! But is it possible to install it on armv7 processor (rpi4 4gb)?

Not able to install in RPi4 with 8 GB.

I get the follow error.

pi@raspberrypi4:~ $ sudo docker run -e VISION-SCENE=True -e VISION-DETECTION=True -e VISION-FACE=True  -p 5000:5000 deepquestai/deepstack:arm64-2021.06.1
WARNING: The requested image's platform (linux/arm64) does not match the detected host platform (linux/arm/v7) and no specific platform was requested
pi@raspberrypi4:~ $

Hello @sjude68 @cigas4

Please enable 64 Bit mode on raspbian following the guide here https://medium.com/@kavoshex/raspian-added-support-for-64-bit-kernel-6cf27c2b26db or install another 64Bit OS on your raspberry pi, Ubuntu Server and Balena OS are good options.

Raspberry PI 3 and 4 both support running 64 bit apps

I have tried after enabling 64bit mode. The same guide was used. After that I reported the problem.

1 Like

Helo @sjude68, after some digging around, I found the 64 Bit images for Raspbian, you can install them from here Index of /raspios_arm64/images (raspberrypi.org)

This should solve the problem.

Thanks @john.
I freshly installed raspberrypios and docker and then Deepstack. The installation went fine. I tried it last night on another sdcard.

But my installation is Raspberry pi os with supervised installation of Home Assistant. On this Deepstack doesn’t install. I followed the procedure to enable 64bit kernel which is running OK. Shows in lscpu command. Something else to do. Maybe I installed 32bit Raspberry pi os. How to update to 64bit os over it.