POST request on detection API endpoint


#1

I have installed deepstack and activated my free subscription key. Here is the system information:
Ubuntu: 16.04 Docker: 18.09.5

I have executed following command with multiple endpoints:
docker run -e VISION-DETECTION=True -e VISION-SCENE=True -e VISION-TRAFFIC=True -v localstorage:/datastore -p 80:5000 deepquestai/deepstack

After that I am getting following error continuously:
./run: line 2: 9444 Aborted (core dumped) python3 /app/intelligence.py &> /dev/null

When I tried sending POSTMAN request as binary as shown in binary-request, I am getting error as below:
{ "success": false, "error": "No valid image file found" }

When I tried sending form request as shown in hanged. I have noticed in terminal that there is no request submitted to server.

Please help me what I am missing here.


#2

Hello, sorry about the error you are experiencing.
Can you share your terminal logs, and also what url are you submitting the image to?


#3

Thank you for your response.
Here is the terminal log file you requested - https://gist.github.com/kamal250/14a49e361d49b283c48e333330a9882b

Here is the local URL I am submitting.


#4

Thanks for sharing this, please run docker run -e VISION-DETECTION=True -v localstorage:/datastore -p 80:5000 deepquestai/deepstack

Here i am enabling only the Detection API.

It is possible that by enabling all the APIs, you might be facing a memory issue.


#5

I started earlier by adding only detection endpoint and later I have added another. Nothing is working and I am getting same result. POST request hangs forever.


#6

Alright, this can be due to a number of factors.
A possible cause is your cpu not supporting avx optimization, in that case, DeepStack has tags for such systems.
What are the full specs of your system. Specifically processor info & RAM ?


#7

Here is system info:
Memory: 4GB
Processor: Intel Pentium CPU G3250 @3.20GHz x 2
OS type: 64-bit


#8

Given your system specs, it does not support a number on instruction sets required by DeepStack. However, we have provided specific builds for legacy systems.

simpy run sudo docker pull deepquestai/deepstack:noavx

When you run, use
sudo docker run -e VISION-DETECTION=True -v localstorage:/datastore -p 80:5000 deepquestai/deepstack:noavx


#9

Thank you so much, it did the trick.


#10

:grinning:You are welcomed