Unable to reach DeepQuest AI server

Help, this is the problem when i am using the detection API. The camera software and the server are on the same machine, DQ is port 80 and the camera system port 81. Can anyone help?

14.10.2019, 22:48:54]: ERROR: Processing the image E:\AI/aigarden.20191014_223104662.jpg failed. Can’t reach DeepQuestAI Server at localhost:80.
[14.10.2019, 22:50:34]: ERROR: Processing the image E:\AI/aigarden.20191014_223105664.jpg failed. Can’t reach DeepQuestAI Server at localhost:80.
[14.10.2019, 22:52:14]: ERROR: Processing the image E:\AI/aigarden.20191014_223106665.jpg failed. Can’t reach DeepQuestAI Server at localhost:80.

were you playing with that AI tool from gentlepumpin?

I have the same issue now. It is due to python crashing when invoked. I have not found a fix yet. Both win10e and win2k19 have the same issue

Im having the same issue and im stumped.
Im running the AI tool on a Win10 Pro 1909 phycial PC. with Deepquest running in a Docker container on a Synology Nas. Can access the DeepQuest activated screen via the browser.

Same Here. I have Tried the
-Windows Version (On Physical PC and VM)
-Docker Versions with AVX and NOAVX and Older Versions as well. (2 Different Virtual Hosts Dell R710 and a Mac Mini 2012, As well as my main Desktop PC.
-Different methods always the same result. Deepstack will activate and is able to get to the web url on all workstations it will also log the connection in deepstack in the docker logs when this occurs, but when AI Tool tries to send the image over it doesn’t see the Deepstack AI Server.

I am Stumped???:disappointed_relieved:

XCP-NG is my Hyperviser for the VM’s that are running Ubuntu 18 Server for the Docker instances.

I too am getting the same issue when running DeepQuest in a docker container hosted in a windows server 2019 Hyper-V. The windows executable runs fine for the AI Tool, but theres no way to automate the start up. AI Tool cannot send images to DeepQuest when run from docker for some reason. Port forwarding is all correct too…

Same problem here.
Already changed port number. when I put in ip and port in a browser I see the welcome screen of the server.

I just followed the YouTube guide by “The Hook up” found that video fraking amazing.
Well here I am now, stuck with you lot…

I am a professional C# Developer and I find the documentation and website to be a bit horrible (compared to many other types of sites, like for example Digital Ocean Documentation and API’s)

Anyywayy. I ran a test using POSTMAN without an attachment and get the result

{
“success”: false,
“error”: “No valid image file found”
}

When I do the same requests as using the AI TOOL… The request just freezes up… no response , nothing in the console (i have it on docker on ubuntu 18) - The failed requests showed up with some stupid nano second response time… but the real deal… just been waiting for a response for 5 minutes plus the time I took to write this.

Not a very nice first time experience not really knowing what the hell is going on

I am going to go and try Azure Cognitive Vision for person detection instead… and modify the AI Tool program to call that because this.


There you go- that is the problem with the latest version
socket hang up hahahah - after 15 minutes

I installed the noavx version it may be my server CPU does not support all the things they need. And that works. (this requires the KEY you can get it again for free during sign up on main page)

But both the docker and windows version just hang like this as mentioned in the post.

I have it all working with AI Tool now using the no avx docker version. But the noavx version is quite old still wants the registration key so there could be a bug in the newest version if it used to work for you. Where it just hangs for some reason during detection.

So AI Tool is running for me know fine and if you want to get it working again i suggest trying the older versions where the key was required or the noavx version (at a penalty in processing speed )

Once it got it working I compared frames results with Azure Cognitive Vision to see how accurate DeepStack is. I think DeepStack is good enough for the CCTV triggering but there seems to be an edge case problem

I’m also having the same problem and would appreciate some help thanks

I had a similar problem after following the The Hook Up youtube video. There was a comment on the YouTube comments suggesting the VM was running out of memory. I increased memory from 2 to 4gb and it now works. Am using the normal latest docker image.

Pete

Solved, i pulled the image on my Unraid server. The following run command is what is used. Seems like it doesn’t need the api key on the docker.
I have to learn how to make a template and add it to the community applications!

docker run -d --name=‘deepstack’ --net=‘bridge’ -e TZ=“Europe/Athens” -e HOST_OS=“Unraid” -e ‘VISION-DETECTION’=‘True’ -e ‘VISION-FACE’=‘True’ -e ‘VISION-SCENE’=‘True’ -p ‘10508:5000/tcp’ -v ‘/mnt/user/appdata/deepstack’:’/datastore’:‘rw’ ‘deepquestai/deepstack’

I’m getting the following error in the AI tool (tried both 1.65 and 1.67 peview 7)

[19.07.2020, 15:23:44.975]: Starting analysis of C:\BlueIris\aiinput/eisodossd.20200719_135500.jpg
[19.07.2020, 15:23:44.983]: (1/6) Uploading image to DeepQuestAI Server
[19.07.2020, 15:23:45.033]: (2/6) Waiting for results
[19.07.2020, 15:23:45.041]: (3/6) Processing results:
[19.07.2020, 15:23:45.047]: System.NullReferenceException | Object reference not set to an instance of an object. (code: -2147467261 )
[19.07.2020, 15:23:45.051]: ERROR: Processing the following image ‘C:\BlueIris\aiinput/eisodossd.20200719_135500.jpg’ failed. Failure in AI Tool processing the image.

On the deepstack docker logs i see

[GIN] 2020/07/19 - 12:23:45 | 401 | 36.601783ms | 10.10.10.247 | POST /v1/vision/detection

Docker run command is

docker run -d --name=‘deepstack’ --net=‘bridge’ -e TZ=“Europe/Athens” -e HOST_OS=“Unraid” -e ‘VISION-DETECTION’=‘True’ -e ‘API-KEY’=‘original-key-values-written-here’ -e ‘VISION-FACE’=‘True’ -e ‘VISION-SCENE’=‘True’ -p ‘10508:5000/tcp’ -v ‘/mnt/user/appdata/deepstack’:’/datastore’:‘rw’ ‘deepquestai/deepstack’

I can’t get past this problem. Any help would be appreciated!

Problem:
AI Tool not able to send .jpg files to DeepStack. Error: Can’t reach DeepQuestAI Server at…

Environment:
HomeAssistant running on Windows Server 2016 Hyper-V
Docker (DeepStack) on HomeAssistant
GentlePumpkin’s AITool https://github.com/gentlepumpkin/bi-aidetection/releases

I’m setting up The Hook Up’s YouTube https://www.youtube.com/watch?v=fwoonl5JKgo&t=387s

I was hoping the beta version of DeepStack (just released) would’ve helped but no joy. Any help would be welcomed and very much appreciated!